Ubuntu Intrepid Woes — Keyboard

It didn’t take long for me to find something wrong with my new installation: the keyboard doesn’t work with remote desktop.

The big problem is that when I connect to my remote computer, the caps lock key doesn’t work.  So, I can’t turn on caps lock.  I tried to compile rdesktop from SourceForge, but that didn’t help.  The caps lock key works with it, but the arrow keys do not.

Here is how I compiled it (just in case you want to try):

sudo apt-get install libx11-dev libssl-dev

I just now found a fix (from the thread).  Change the file /usr/share/rdesktop/keymaps/common .  Change the line that says “Caps_Lock 0x0 inhibit” to “Caps_Lock 0x3a capslock”.  I tried it out and everything works!

Now, I did have a couple of other issues.  I use a docking station at work, and the caps lock key works weirdly with it: pushing the key turns caps lock on and off, but it does not turn the caps lock light on or off.  Also, I have VMWare installed, and the arrow keys and such don’t work with the console.  Changing this common file, and it does not fix the problem.


9 thoughts on “Ubuntu Intrepid Woes — Keyboard

  1. Note that this solution did not work for me, however if I removed the line that says “Caps_Lock 0×0 inhibit” and leave nothing in its place, I know have caps lock working.

  2. For me, commenting out the Caps_Lock line provides only a momentary fix. Moving to another window (this is in Access on Windows, from Linux Mint 7rc1) with returns caps to lowercase but doesn’t turn off the caps lock light. I tried using the keymaps set from an rdesktop 1.5 installation, but the behavior didn’t change.

  3. Changing “Caps_Lock 0x0 inhibit” to “Caps_Lock 0x3a capslock” works but another problem appears. When you press a CAPS LOCK a 5 (or another numpad key), CAPS LOCK, a, 5, a, you will obtain aA5A5a instead of aA5a5a.
    The numpad keys invert the caps lock but do not turn the caps lock light.

  4. This worked for us too, but there is another problem that isn’t fixed; namely, when in MS Excel if you type in “-8” (or whatever number) you get just “8” in the cell, i.e. it ignores the “-“. However, if you type in “8” then backspace then type in “-8”, you get “-8”.

Leave a Comment

Your email address will not be published. Required fields are marked *