Issues with LibreOffice 5.4

I upgraded LibreOffice the other day and ran into a few issues. Here are my notes. Please comment if you find better fixes or details than what I found.


First, it wouldn’t open. It would show the splash screen and then just close. When I ran it from the command line, I got this:

$ libreoffice 
/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/ undefined symbol: _ZN8MsLangId13getScriptTypeEt

To fix it, I just ran all of the updates. It must have been some requirement in the packaging, and it was fixed by the time I realized the problem.

Dark Theme too hard to read

I use the notebook bar with LibreOffice Writer. The problem now is that the background was changed to black. The text color is a dark gray that is almost impossible to read.

I found one article that suggested changing the GTK theme. It didn’t seem to help, but here is the command in case it helps:

GTK_THEME=Adwaita:light libreoffice

I found that I could tweak the appearance in the options. Go to Tools > Options …

  • LibreOffice > Personalization — you can pick a different theme (only changed the background of the notebook bar for me)
  • LibreOffice > Application Colors — the only thing that really seem to help in this case is “Application Background”
  • LibreOffice > View — I could change the Icon theme here

For the time-being, I fixed it by changing the Firefox theme on the personalization settings.


Leave a Comment

Your email address will not be published. Required fields are marked *